Preparando el entorno de desarrollo SAPUI5 en nuestra maquina Linux

Ahora que ya tenemos nuestro servidor SAP en casa y que ya tenemos un sistema Gateway a nuestra disposición es momento de preparar el entorno para poder desarrollar en SAPUI5.

Para ello instalaremos VS Code, NPM y los recursos NPM relacionados con SAPUI5, es decir, las librerías necesarias y los plugins de VS Code.

Instalando VS Code

Lo primero es descargar VS Code, así ya tendremos también la consola integrada para las siguientes operaciones.

Vamos a la página de descarga https://code.visualstudio.com/download y allí nos descargamos el fichero .deb (Debian, Ubuntu)

Una vez descargado, vamos al terminal y ejecutamos:

sudo apt install ./code_1.82.2-1694671812_amd64.deb

Este será el resultado:

Lo siguiente es actualizar los paquetes de microsoft… si… VS Code es de Microsoft 😉

sudo apt-get install wget gpg
wget -qO- https://packages.microsoft.com/keys/microsoft.asc | gpg --dearmor > packages.microsoft.gpg
sudo install -D -o root -g root -m 644 packages.microsoft.gpg /etc/apt/keyrings/packages.microsoft.gpg
sudo sh -c 'echo "deb [arch=amd64,arm64,armhf signed-by=/etc/apt/keyrings/packages.microsoft.gpg] https://packages.microsoft.com/repos/code stable main" > /etc/apt/sources.list.d/vscode.list'
rm -f packages.microsoft.gpg

Este es el resultado

Seguimos actualizando paquetes y por fin instalamos VS Code:

sudo apt install apt-transport-https
sudo apt update
sudo apt install code # or code-insiders

Y este será el resultado:

Y ya tenemos VS Code en nuestro sistema. Para ejecutarlo podemos escribir «code» en el terminal o des del botón de menú:

Instalando NPM

Ahora que ya tenemos VS Code, vamos con los paquetes NPM, esto será tan sencillo como ejecutar en el terminal:

sudo apt-get install nodejs npm

Cuando termine la instalación veremos:

Y ya podemos hacer la prueva:

Instalando plugins VS Code Fiori tools

Vamos a VS Code e instalamos los plugins que nos retorna el buscador al escribir «Fiori Tools»

Nos queda un último paso ya que sin el, no nos funcionará el wizard.

Instalando Yeoman

Ahora necesitaremos los generadores de proyectos Fiori mediante el asistente Yeoman.

Para instalarlo:

sudo npm install -g yo

Esto nos indicará que ya tenemos instalado el generador:

Ahora instalamos el generador de SAP UI5:

npm install -g yo generator-easy-ui5

Instalaremos también:

npm install --global @ui5/cli

Resultado:

Para verificar que es correcta la instalación, seleccionamos «View» -> «Command Palete» y buscamos «Template Wizard» :


Poco a poco ya tenemos el pack fullstack para concentrar todo el desarrollo local en nuestra máquina virutal. Con esta entrada, ya podremos desarrollar la parte Front.

Como siempre suscribete, dale a la campanita de notificaciones y comparte en redes ayudarme a llegar a más personas.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.